知一的指纹

pip、easy_install相关

版权声明: 本文为博主原创文章,发表自 知一的指纹。转载需向 我的邮箱 申请。

pip更新python -m pip install -U pip

pipy国内镜像目前有:

http://pypi.douban.com/ 豆瓣
http://pypi.hustunique.com/ 华中理工大学
http://pypi.sdutlinux.org/ 山东理工大学
http://pypi.mirrors.ustc.edu.cn/ 中国科学技术大学


指定源安装

pip可以通过指定源的方式安装pip install web.py -i http://pypi.douban.com/simple

也可以通过修改配置文件:
Linux的文件在~/.pip/pip.conf,Windows在%HOMEPATH%\pip\pip.ini
文件内容:

1
2
[global]
index-url = http://pypi.douban.com/simple

easy_install指定源安装easy_install -i http://pypi.douban.com/simple

修改配置文件:
编辑文件vim ~/.pydistutils.cfg,写入文件内容如下:

1
2
[easy_install]
index_url = http://e.pypi.python.org/simple


安装Python安装包管理工具相关命令

安装easy_install:apt-get install python-setuptools
sudo yum install python-setuptools-devel
esay_install pip
pip指定版本:pip install 'pymongo<2.8'
升级版本:pip install --upgrade pymongo
查看已安装包:pip show --files SomePackage
查看需要更新的包:pip list --outdated
卸载包:pip uninstall SomePackage
帮助:pip --help
指定豆瓣源安装:pip install -i http://pypi.douban.com/simple/ functools32
查看已安装包:pip list

http://www.cnblogs.com/taosim/articles/3288821.html


Windows安装pip

1.安装附件 get-pip.py就好了。
2.添加脚本路径C:\Python27\Scripts到系统环境变量。


easy_install查看包的版本

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
root@xyz-pc:~# easy_install tornado -v
Searching for tornado
Best match: tornado 4.0.2
tornado 4.0.2 is already the active version in easy-install.pth

Using /usr/lib/python2.7/dist-packages
Processing dependencies for tornado
Finished processing dependencies for tornado
Searching for -v
Reading https://pypi.python.org/simple/-v/
Couldn't find index page for '-v' (maybe misspelled?)
Scanning index of all packages (this may take a while)
Reading https://pypi.python.org/simple/
No local packages or download links found for -v
error: Could not find suitable distribution for Requirement.parse('-v')

如果此文章能给您带来小小的提升,不妨小额赞赏我一下,以鼓励我写出更好的文章!
Noogel's WeChat Pay

微信打赏

Noogel's Alipay

支付宝打赏